Drop support for WordPress versions prior to 4.9
Currently we state that we support WordPress versions back to 3.4 "WordPress 3.4.x or newer is required."
However, CiviCRM won't run on all older versions of WP. As WP itself raised it's minimum requirements to php 5.6 in version 5.2 it's time to change the minimum required version.
So why Version 4.9?
4.9 was released on November 15 2017 and is fully compatible with php versions up to 7.2 4.9 will support our current ESR release and our upcoming releases until we drop php 7.2 support. I expect that will cover us for quite some time.