!3 PHP 7.4 compatibility (Regen civix by @kcristiano)