This version works with CiviCRM v4.4.x All improvements and fixes to the codebase will be made on the 4.4.x version only