1. 19 Dec, 2019 1 commit
  2. 16 Dec, 2019 2 commits
  3. 03 Dec, 2019 1 commit
  4. 25 Nov, 2019 3 commits
  5. 15 Nov, 2019 2 commits
  6. 14 Nov, 2019 2 commits
  7. 11 Nov, 2019 1 commit
    • kcristiano's avatar
      Only redirect if CiviCRM is not already installed · fd89e9c4
      kcristiano authored
      
      If you install via CLI you will get redirected to setup page first time you go to CiviCRM in admin menu - fine if you did not do a CLI install `cv core:install` But if you did you get a you are not allowed to access this page message.
      
      Need to add a check to see if `CIVICRM_INSTALLED` before doing the redirect.  This will also cover deactivating and reactivating for testing.
      fd89e9c4
  8. 07 Nov, 2019 2 commits
  9. 14 Oct, 2019 3 commits
  10. 09 Oct, 2019 1 commit
  11. 06 Oct, 2019 1 commit
  12. 01 Sep, 2019 1 commit
  13. 21 Aug, 2019 3 commits
  14. 20 Aug, 2019 3 commits
    • kcristiano's avatar
      Merge pull request #161 from totten/5.17-php-min · 89fb4a4d
      kcristiano authored
      (drupal#79) Fail more gracefully when upgrading on PHP 5.x
      89fb4a4d
    • totten's avatar
      Fail more gracefully when installing on PHP 5.x · c3b04668
      totten authored
      c3b04668
    • totten's avatar
      (drupal#79) Fail more gracefully when upgrading on PHP 5.x · 71aa9bee
      totten authored
      This version requirement officially went up to PHP 7.0 circa Civi 5.14.
      However, at that time, the upgrade metadata was kept at PHP 5.6 to allow
      somewhat softer landing for stragglers.  That's no longer possible in Civi
      5.16+,
      
      This just gives a clearer error when someone tries to upgrade with PHP 5.x.
      
      Before
      ------
      
      When accessing a Civi-WordPress site on PHP 5.6 (or running wp-cli), the Civi class-loader fails to initialize.
      
      ```
      Parse error: syntax error, unexpected ':', expecting '{' in /Users/totten/bknix/build/dmaster/web/sites/all/modules/civicrm/vendor/league/csv/src/functions.php on line 33
      ```
      
      (Approximate call-path: `civicrm.php` => `civicrm.settings.php` =>
      `CRM_Core_ClassLoader` => `vendor/autoload.php` => `vendor/league/csv/src/functions.php`)
      
      After
      -----
      
      When accessing a Civi-WordPress site on PHP 5.6 (or running wp-cli), the error message is:
      
      ```
      CiviCRM requires PHP version 7.0.0 or greater. You are running PHP version 5.6.38
      ```
      
      Comments
      --------
      
      The canonical representation of the minimum PHP version is in
      `$civicrm_root/CRM/Upgrade/Form.php`.  However, correctly reading that
      metadata requires loading `civicrm.settings.php`, which triggers the crash.
      
      To work around this, this patch reproduces the constant and uses a unit-test
      to ensure its continued accuracy.
      71aa9bee
  15. 14 Jun, 2019 2 commits
  16. 13 Jun, 2019 1 commit
  17. 12 Jun, 2019 1 commit
  18. 07 Jun, 2019 1 commit
  19. 06 Jun, 2019 1 commit
  20. 27 Apr, 2019 2 commits
  21. 26 Apr, 2019 1 commit
  22. 25 Apr, 2019 3 commits
  23. 24 Apr, 2019 1 commit
  24. 19 Mar, 2019 1 commit