1. 04 Apr, 2019 1 commit
  2. 21 Feb, 2019 1 commit
  3. 18 Jul, 2018 1 commit
  4. 20 Sep, 2017 1 commit
  5. 22 Jun, 2017 1 commit
    • totten's avatar
      CRM-20756 - Add Angular `ui.bootstrap` library · e88c001e
      totten authored
      This adds the library
      [ui.bootstrap](https://angular-ui.github.io/bootstrap/), which makes it
      easier to include the functional elements of Bootstrap in AngularJS pages.
      
      In the past, adding this was problematic, but now the situation has
      improved:
      
      1.  civicrm-core has upgraded to AngularJS 1.5.  (In the past, civicrm-core
      used AngularJS 1.3, which was incompatible.)
      
      2.  civicrm-core allows optional AngularJS modules.  (In the past, all
      modules were loaded unconditionally, which could result in loading
      new/unnecessary code for legacy users.  Now, you can opt-out of this
      behavior with `basePages=>array()`.)
      e88c001e
  6. 12 Jun, 2017 1 commit
  7. 26 May, 2017 1 commit
  8. 06 Feb, 2017 1 commit
  9. 15 Dec, 2016 1 commit
  10. 13 Oct, 2015 1 commit
  11. 29 Jul, 2015 1 commit
  12. 14 Jul, 2015 1 commit
  13. 07 Jul, 2015 1 commit
  14. 30 Apr, 2015 2 commits
  15. 25 Apr, 2015 1 commit
  16. 22 Mar, 2015 2 commits
  17. 09 Feb, 2015 1 commit
  18. 05 Feb, 2015 1 commit
  19. 30 Jan, 2015 3 commits
  20. 10 Jan, 2015 2 commits
  21. 08 Jan, 2015 1 commit
  22. 30 Dec, 2014 1 commit
    • peterh's avatar
      Get the distmaker working with npm and bower. · 8c70cd69
      peterh authored
      We're going to start distributing the node_modules and bower_modules
      using npm and bower now instead of having them in packages because we
      feel that those are a better way to manage backages than the packages
      repository. So the distmaker needs to copy those directories to the
      distribution after running 'npm install' to get the packages downloaded.
      
      Also I needed to put a resolution for the angular version in the
      bower.json file because some of the angular plugins were resolving to
      angular 1.2.x and we want 1.3.x. I also changed the version numbers to
      start at 1.3.8, but allow minor version updates because that's what
      we're using.
      8c70cd69
  23. 23 Dec, 2014 1 commit
    • peterh's avatar
      The start of a test framework for Angular. · 416abe87
      peterh authored
      To run:
      npm install
      npm test
      
      The beginnings of some tests for the new Angular code. Includes some tests
      for the case type stuff and the new mailing stuff.
      416abe87