1. 22 Aug, 2019 3 commits
  2. 21 Aug, 2019 2 commits
    • totten's avatar
      composer.lock - Run: "composer update php" · 133dc2c2
      totten authored
    • totten's avatar
      (drupal#79) Fail more gracefully when attempting to install on PHP 5.x · 1f180621
      totten authored
      If an admin stracts the code and navigates to `/sites/all/modules/civicrm/install/index.php`, it displays
      a syntax error.
      If an admin stracts the code and navigates to `/sites/all/modules/civicrm/install/index.php`, it displays
      the message:
      > __PHP Version Requirement__
      > CiviCRM requires PHP 7.0+. The web server is running PHP 5.6.38.
      This is similar to https://github.com/civicrm/civicrm-drupal/pull/583
      The canonical representation of the minimum PHP version is in
      `$civicrm_root/CRM/Upgrade/Form.php`.  However, setting up the classloader
      triggers a syntax error, so we need to read this without having access to
      the classloader.
      The approach herein has a few effects:
      * The minimum PHP can be read from a JSON file.
      * That JSON file is also used by `composer`, so you'll also get better errors when downloading that way.
      * At some unknown point, the minimum will probably bump up again (7.1 or 7.2 or whatever). When that
        happens, the unit-test will ensure we keep `CRM/Upgrade/Form.php` and `composer.json` in sync.
      Note: I was little concerned that the `composer.json` file might not be
      available when normal installers run, so I checked the published tarballs
      for D7, BD, WP, and J - in all cases, the `composer.json` looks to be
      included at the expected location.
  3. 20 Aug, 2019 8 commits
  4. 18 Aug, 2019 1 commit
  5. 17 Aug, 2019 5 commits
  6. 15 Aug, 2019 4 commits
  7. 14 Aug, 2019 2 commits
  8. 12 Aug, 2019 5 commits
  9. 09 Aug, 2019 2 commits
  10. 08 Aug, 2019 8 commits