Commit 6a77bdf4 authored by totten's avatar totten

CRM-20243 - bower.json - Upgrade to Angular 1.5.x

Two reasons:
 * Angular 1.3.x is no longer maintained.
 * This is one step toward bringing the CiviCRM and CiviHR codebases into alignment.
parent 6df83fb2
...@@ -5,11 +5,11 @@ ...@@ -5,11 +5,11 @@
"license": "AGPL-3.0", "license": "AGPL-3.0",
"private": true, "private": true,
"dependencies": { "dependencies": {
"angular": "~1.3.8", "angular": "~1.5.0",
"angular-file-upload": ">=1.1.5 <=1.1.6", "angular-file-upload": ">=1.1.5 <=1.1.6",
"angular-jquery-dialog-service": "totten/angular-jquery-dialog-service#civicrm", "angular-jquery-dialog-service": "totten/angular-jquery-dialog-service#civicrm",
"angular-mocks": "~1.3.8", "angular-mocks": "~1.5.0",
"angular-route": "~1.3.8", "angular-route": "~1.5.0",
"angular-ui-sortable": "0.12.x", "angular-ui-sortable": "0.12.x",
"angular-ui-utils": "0.1.x", "angular-ui-utils": "0.1.x",
"angular-unsavedChanges": "~0.1.1", "angular-unsavedChanges": "~0.1.1",
...@@ -25,9 +25,10 @@ ...@@ -25,9 +25,10 @@
"jstree": "~3", "jstree": "~3",
"ckeditor": "~4.5", "ckeditor": "~4.5",
"font-awesome": "~4", "font-awesome": "~4",
"angular-sanitize": "~1.3.15" "angular-sanitize": "~1.5.0",
"phantomjs-polyfill": "^0.0.2"
}, },
"resolutions": { "resolutions": {
"angular": "~1.3.8" "angular": "~1.5.11"
} }
} }
...@@ -5,6 +5,7 @@ module.exports = function(config) { ...@@ -5,6 +5,7 @@ module.exports = function(config) {
exclude: [ exclude: [
], ],
files: [ files: [
'bower_components/phantomjs-polyfill/bind-polyfill.js',
'bower_components/jquery/dist/jquery.min.js', 'bower_components/jquery/dist/jquery.min.js',
'bower_components/jquery-ui/jquery-ui.min.js', 'bower_components/jquery-ui/jquery-ui.min.js',
'bower_components/lodash-compat/lodash.min.js', 'bower_components/lodash-compat/lodash.min.js',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment