Commit 4d4b6acd authored by Andrew Hunt's avatar Andrew Hunt

5.17.0 release notes: late changes and tidy-up

parent c1b970ad
...@@ -28,7 +28,7 @@ Released September 4, 2019 ...@@ -28,7 +28,7 @@ Released September 4, 2019
## CiviCRM 5.16.4 ## CiviCRM 5.16.4
Released Sep 3, 2019 Released September 3, 2019
- **[Synopsis](release-notes/5.16.4.md#synopsis)** - **[Synopsis](release-notes/5.16.4.md#synopsis)**
- **[Bugs resolved](release-notes/5.16.4.md#bugs)** - **[Bugs resolved](release-notes/5.16.4.md#bugs)**
......
...@@ -13,13 +13,13 @@ Released September 4, 2019 ...@@ -13,13 +13,13 @@ Released September 4, 2019
| *Does this version...?* | | | *Does this version...?* | |
|:--------------------------------------------------------------- |:-------:| |:--------------------------------------------------------------- |:-------:|
| Fix security vulnerabilities? | | | Fix security vulnerabilities? | no |
| Change the database schema? | **yes** | | **Change the database schema?** | **yes** |
| Alter the API? | **yes** | | **Alter the API?** | **yes** |
| Require attention to configuration options? | | | Require attention to configuration options? | no |
| Fix problems installing or upgrading to a previous version? | **yes** | | **Fix problems installing or upgrading to a previous version?** | **yes** |
| Introduce features? | **yes** | | **Introduce features?** | **yes** |
| Fix bugs? | **yes** | | **Fix bugs?** | **yes** |
## <a name="features"></a>Features ## <a name="features"></a>Features
...@@ -580,13 +580,15 @@ Released September 4, 2019 ...@@ -580,13 +580,15 @@ Released September 4, 2019
Fixes a call to `languageNegotiationURL` that was causing cv to fail on Drupal Fixes a call to `languageNegotiationURL` that was causing cv to fail on Drupal
8 sites. 8 sites.
- **Error when upgrading to 5.16.0 - **Fail more gracefully when attempting to install on PHP 5.x
([dev/drupal#79](https://lab.civicrm.org/dev/drupal/issues/79): ([dev/drupal#79](https://lab.civicrm.org/dev/drupal/issues/79):
[15082](https://github.com/civicrm/civicrm-core/pull/15082))** [15082](https://github.com/civicrm/civicrm-core/pull/15082) and
[15089](https://github.com/civicrm/civicrm-core/pull/15089))**
Raises the `MINIMUM_PHP_VERSION` from 5.6 to 7.0 in the metadata because when Raises the `MINIMUM_PHP_VERSION` from 5.6 to 7.0 in the metadata because when
upgrading via drush or Drupal web UI to Civi 5.16+ on PHP 5.6, the Civi upgrading via drush or Drupal web UI to Civi 5.16+ on PHP 5.6, the Civi
class-loader fails to initialize. class-loader fails to initialize. The installer is also updated to check the
PHP version before proceeding with the class loader.
- **Migrate CivicrmHelper::parseUrl() to CRM_Utils_System_Drupal8::parseUrl(). - **Migrate CivicrmHelper::parseUrl() to CRM_Utils_System_Drupal8::parseUrl().
([14696](https://github.com/civicrm/civicrm-core/pull/14696))** ([14696](https://github.com/civicrm/civicrm-core/pull/14696))**
...@@ -978,6 +980,9 @@ Released September 4, 2019 ...@@ -978,6 +980,9 @@ Released September 4, 2019
- **[NFC] comment fixes, function mis-casing fix - **[NFC] comment fixes, function mis-casing fix
([14906](https://github.com/civicrm/civicrm-core/pull/14906))** ([14906](https://github.com/civicrm/civicrm-core/pull/14906))**
- **[NFC] comment
fixes([15197](https://github.com/civicrm/civicrm-core/pull/15197))**
## <a name="credits"></a>Credits ## <a name="credits"></a>Credits
This release was developed by the following code authors: This release was developed by the following code authors:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment