Commit 841e8d90 authored by mattwire's avatar mattwire
Browse files

Release 6.0.alpha3

parent a4421acd
...@@ -11,7 +11,7 @@ use CRM_Stripe_ExtensionUtil as E; ...@@ -11,7 +11,7 @@ use CRM_Stripe_ExtensionUtil as E;
*/ */
class CRM_Stripe_Check { class CRM_Stripe_Check {
const MIN_VERSION_MJWSHARED = 0.2; const MIN_VERSION_MJWSHARED = 0.3;
public static function checkRequirements(&$messages) { public static function checkRequirements(&$messages) {
$extensions = civicrm_api3('Extension', 'get', [ $extensions = civicrm_api3('Extension', 'get', [
......
## Release 6.0.alpha3
* Support recurring payments with paymentIntents/Elements. Cancel subscription with Stripe when we reach recurring end date
* **Update required Stripe API version to 2019-09-09**
* Handle confirmation pages properly for contribution pages (make sure we pass through paymentIntentID).
* Handle card declined on client side.
* Support creating recurring payment (subscription).
* Handle IPN events for charges / invoices (support cancel/refund etc).
* Add basic support for PaymentProcessor.refund API.
* Remove membership_type_tag from plan name.
## Release 6.0.alpha2 ## Release 6.0.alpha2
* Support Drupal Webform CiviCRM. * Support Drupal Webform CiviCRM.
......
...@@ -12,8 +12,8 @@ ...@@ -12,8 +12,8 @@
<author>Matthew Wire (MJW Consulting)</author> <author>Matthew Wire (MJW Consulting)</author>
<email>mjw@mjwconsult.co.uk</email> <email>mjw@mjwconsult.co.uk</email>
</maintainer> </maintainer>
<releaseDate>2019-09-06</releaseDate> <releaseDate>2019-09-10</releaseDate>
<version>6.0.alpha2</version> <version>6.0.alpha3</version>
<develStage>alpha</develStage> <develStage>alpha</develStage>
<compatibility> <compatibility>
<ver>5.13</ver> <ver>5.13</ver>
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment